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Watch	
  video	
  tutorials	
  
AWR	
  Design	
  Environment	
  (Microwave	
  Office)	
  tutorials	
  are	
  found	
  at	
  the	
  following	
  link:	
  
http://www.aaronscher.com/Microwave_office_video_tutorials/Microwave_office_video_tutorials.html	
  
	
  
This	
  assignment	
  is	
  based	
  on	
  the	
  following	
  tutorials	
  (found	
  by	
  clicking	
  the	
  link	
  above)	
  
Video	
  5:	
  How	
  to	
  use	
  Microwave	
  Office's	
  TXLine	
  to	
  design	
  a	
  50	
  Ohm	
  microstrip	
  line	
  
Video	
  6:	
  How	
  to	
  use	
  Microwave	
  Office’s	
  EM	
  Extract	
  to	
  setup	
  and	
  run	
  EM	
  simulation	
  from	
  the	
  
schematic 
	
  
Simulate	
  a	
  microstrip	
  patch	
  antenna	
  from	
  the	
  schematic	
  (based	
  partly	
  on	
  Video	
  5)	
  
In	
  this	
  example	
  we	
  are	
  going	
  to	
  simulate	
  the	
  microstrip	
  patch	
  antenna	
  that	
  designed	
  in	
  Example	
  
3.4	
  in	
  Ref	
  [1]	
  using	
  AWR	
  Microwave	
  Office.	
  Figure	
  1	
  shows	
  the	
  layout	
  of	
  a	
  microstrip	
  patch	
  
antenna.	
  The	
  operating	
  frequency	
  is	
  3	
  GHz.	
  The	
  substrate	
  is	
  Duroid	
  5880	
  (εr = 2.2 )	
  with	
  a	
  
thickness	
  of	
  0.030	
  in	
  (assume	
  zero	
  loss	
  tangent	
  and	
  1	
  oz	
  copper	
  board).	
  The	
  antenna	
  is	
  fed	
  by	
  a	
  
50	
  Ohm	
  line,	
  and	
  a	
  quarter	
  wavelength	
  transformer	
  is	
  used	
  for	
  impedance	
  matching.	
  Example	
  
3.4	
  in	
  Ref	
  [1]	
  yields	
  the	
  following	
  the	
  dimensions:	
  
	
  
w2	
  =	
  .228	
  cm	
  
w1=.0442	
  cm	
  
ℓ1 = 1.90	
  cm	
  
W=3.95	
  cm	
  
L=3.34	
  cm	
  

	
  

	
  
Figure	
  1.	
  	
  Microstrip	
  patch	
  antenna	
  

	
  
Part	
  I.	
  Simulate	
  the	
  circuit	
  schematic	
  
	
  
Please	
  follow	
  these	
  steps	
  to	
  complete	
  part	
  I.	
  	
  
	
  

1. Create	
  a	
  new	
  schematic	
  called	
  Schematic_Simulation.	
  
2. Choose	
  Options > Project Options.	
  Under	
  the	
  Frequency	
  tab	
  set	
  the	
  frequency	
  range	
  to	
  be	
  

2.5	
  to	
  3.5	
  GHz	
  with	
  a	
  step	
  size	
  of	
  0.001	
  GHz.	
  Under	
  the	
  Global Units	
  tab,	
  set	
  the	
  project	
  
units	
  for	
  frequency	
  to	
  be	
  GHz	
  and	
  length	
  to	
  be	
  in	
  cm.	
  	
  

3. In	
  the	
  schematic	
  window,	
  construct	
  a	
  model	
  of	
  the	
  microstrip	
  patch	
  antenna	
  using	
  three	
  
segments	
  of	
  transmission	
  lines	
  like	
  that	
  shown	
  in	
  Figure	
  2.	
  Note	
  that	
  the	
  50	
  Ohm	
  line	
  
(connecting	
  port	
  1	
  to	
  the	
  antenna)	
  is	
  arbitrarily	
  set	
  to	
  be	
  1	
  cm	
  long.	
  	
  

4. Choose	
  Project > Add Graph.	
  Create	
  a	
  rectangular	
  graph.	
  	
  Right	
  click	
  on	
  the	
  graph	
  and	
  
select	
  Add New Measurement.	
  Set	
  the	
  measurement	
  to	
  be	
  S11	
  in	
  dB.	
  



5. Once	
  the	
  measurement	
  is	
  setup,	
  choose	
  Simulate > Analyze to	
  analyze	
  the	
  circuit.	
  You	
  
should	
  see	
  a	
  dip	
  in	
  S11	
  around	
  3GHz.	
  	
  Take	
  a	
  screenshot	
  of	
  S11	
  and	
  turn	
  this	
  in	
  with	
  your	
  
assignment.	
  	
  

	
  
	
  

	
  
	
  
Figure	
  2.	
  AWR	
  Microwave	
  office	
  schematic	
  of	
  the	
  microstrip	
  patch	
  antenna	
  using	
  MLIN	
  model	
  
and	
  MLEF	
  models	
  
	
  
Part	
  II.	
  Run	
  an	
  EM	
  simulation	
  from	
  the	
  schematic.	
  	
  
	
  

1. To	
  duplicate	
  your	
  schematic,	
  right	
  click	
  Circuit Schematics	
  in	
  the	
  Project	
  Browser	
  (located	
  
by	
  default	
  on	
  the	
  left	
  column	
  of	
  the	
  window),	
  choose	
  Duplicate Schematic.	
  The	
  default	
  
name	
  will	
  be	
  Schematic_Simulation_1.	
  Change	
  the	
  name	
  by	
  right	
  clicking	
  on	
  
Schematic_Simulation_1	
  in	
  the	
  Project	
  Browser,	
  choose Rename Schematic	
  and	
  rename	
  the	
  
schematic	
  to	
  EM_Simulation.	
  This	
  will	
  be	
  the	
  schematic	
  that	
  we	
  will	
  work	
  on	
  for	
  Part	
  2.	
  	
  

2. Following	
  the	
  basic	
  procedure	
  from	
  Video	
  6,	
  use	
  the	
  EM	
  extract	
  feature	
  to	
  setup	
  an	
  EM	
  
simulation	
  from	
  the	
  schematic.	
  Keep	
  the	
  X_cell_size	
  and	
  X_cell_size	
  as	
  their	
  default	
  
values	
  (1	
  cm).	
  For	
  your	
  reference,	
  here	
  is	
  the	
  set	
  of	
  steps	
  to	
  accomplish	
  this:	
  
	
  

a. With	
  the	
  schematic	
  EM_Simulation	
  active,	
  choose	
  Scripts > EM > Create Stackup	
  
and	
  press	
  OK.	
  	
  An	
  EXTRACT	
  block	
  and	
  a	
  STACKUP	
  block	
  should	
  appear	
  in	
  your	
  
schematic.	
  	
  

b. Double	
  click	
  on	
  the	
  STACKUP	
  block	
  in	
  the	
  schematic.	
  Click	
  on	
  the	
  EM Layer 
Mapping	
  tab.	
  You	
  will	
  see	
  a	
  list	
  of	
  drawing	
  layers.	
  The	
  third	
  row	
  down	
  is	
  named	
  
“Copper”	
  (it	
  coincides	
  with	
  EM	
  layer	
  2).	
  Change	
  the	
  material	
  from	
  <blank>	
  to	
  
“CU”	
  (i.e.	
  copper).	
  	
  You	
  can	
  do	
  this	
  by	
  clicking	
  on	
  the	
  blank	
  material	
  box	
  in	
  this	
  
row.	
  	
  Now	
  click	
  on	
  the	
  Line Type	
  tab.	
  Insert	
  a	
  new	
  line	
  by	
  clicking	
  on	
  the	
  Insert	
  
button.	
  	
  Change	
  the	
  material	
  name	
  to	
  “CU”	
  and	
  make	
  sure	
  the	
  EM	
  layer	
  is	
  set	
  to	
  
be	
  2.	
  Delete	
  all	
  other	
  lines	
  in	
  this	
  window	
  so	
  you	
  only	
  have	
  the	
  one	
  line	
  you	
  
created.	
  This	
  procedure	
  is	
  presented	
  in	
  Video	
  6.	
  Click	
  OK	
  to	
  return	
  to	
  the	
  
schematic	
  window.	
  	
  

c. Now	
  right	
  click	
  any	
  one	
  of	
  your	
  transmission	
  line	
  segments	
  in	
  the	
  schematic	
  and	
  
choose	
  Properties.	
  Click	
  on	
  the	
  Model Options	
  tab.	
  Check	
  the	
  Enable	
  box	
  to	
  enable	
  
EM	
  extraction	
  for	
  this	
  element	
  and	
  click	
  OK	
  to	
  return	
  to	
  the	
  schematic	
  window.	
  
Follow	
  this	
  same	
  procedure	
  for	
  the	
  other	
  two	
  transmission	
  line	
  segments	
  to	
  
enable	
  EM	
  extraction	
  for	
  them	
  as	
  well.	
  	
  

d. Right	
  click	
  on	
  the	
  EXTRACT	
  block	
  in	
  the	
  schematic	
  and	
  select	
  Add Extraction. A	
  
new	
  EM	
  structure	
  will	
  be	
  created.	
  By	
  default,	
  you	
  should	
  be	
  now	
  viewing	
  the	
  



patch	
  antenna	
  in	
  the	
  EM	
  simulator	
  (you	
  will	
  have	
  a	
  top	
  down	
  view	
  of	
  the	
  
antenna).	
  If	
  the	
  EM	
  simulator	
  is	
  not	
  open,	
  then	
  double	
  click	
  on	
  EM_Extract_Doc	
  
under	
  EM Structures	
  in	
  the	
  Project	
  Browser	
  to	
  open	
  it.	
  

	
  
3. In	
  the	
  EM	
  simulator,	
  choose	
  	
  View > View EM Layout	
  for	
  a	
  3D	
  view	
  of	
  the	
  patch	
  antenna.	
  

Take	
  screenshot	
  of	
  a	
  3D	
  view	
  of	
  the	
  patch	
  antenna	
  and	
  turn	
  this	
  in	
  with	
  your	
  
assignment.	
  To	
  go	
  back	
  to	
  the	
  regular	
  top-­‐down	
  view,	
  choose	
  View > View EM layout.	
  

4. In	
  the	
  EM	
  simulator,	
  click	
  on	
  the	
  Show 2D Mesh	
  	
  in	
  the	
  toolbar	
  (the	
  tool	
  bar	
  is	
  a	
  row	
  of	
  
buttons	
  located	
  just	
  below	
  the	
  menu	
  bar	
  that	
  provides	
  shortcuts	
  to	
  frequently	
  used	
  
commands).	
  Take	
  a	
  screenshot	
  of	
  the	
  mesh	
  and	
  turn	
  this	
  in	
  with	
  your	
  assignment.	
  

6. We	
  want	
  to	
  compare	
  S11	
  obtained	
  using	
  the	
  schematic	
  simulator	
  with	
  that	
  obtained	
  
using	
  the	
  AXIEM	
  EM	
  simulator.	
  To	
  do	
  this,	
  choose	
  Project > Add Graph.	
  Create	
  a	
  
rectangular	
  graph.	
  	
  Right	
  click	
  on	
  the	
  graph	
  and	
  select	
  Add New Measurement.	
  Select	
  
Schematic_Simulation	
  as	
  the	
  Data	
  Source	
  Name	
  and	
  set	
  the	
  measurement	
  to	
  be	
  S11	
  in	
  dB	
  
and	
  click	
  the	
  Apply	
  button.	
  Now	
  select	
  EM_Simulation	
  as	
  the	
  Data	
  Source	
  Name	
  and	
  set	
  
the	
  measurement	
  to	
  be	
  S11	
  in	
  dB	
  and	
  click	
  Apply	
  then	
  OK.	
  	
  	
  

7. Once	
  the	
  measurement	
  is	
  setup,	
  choose	
  Simulate > Analyze to	
  analyze	
  the	
  circuit.	
  EM	
  
simulations	
  are	
  generally	
  slow	
  and	
  this	
  one	
  may	
  take	
  a	
  few	
  minutes	
  depending	
  on	
  your	
  
computer	
  speed	
  and	
  memory.	
  	
  When	
  the	
  simulation	
  is	
  finished,	
  you	
  should	
  now	
  be	
  
looking	
  at	
  two	
  plots	
  of	
  S11	
  in	
  dB	
  on	
  the	
  same	
  graph.	
  Take	
  a	
  screenshot	
  of	
  this	
  graph	
  and	
  
turn	
  this	
  in	
  with	
  your	
  assignment.	
  Both	
  simulators	
  plots	
  should	
  display	
  a	
  resonant	
  dip	
  
around	
  3	
  GHz.	
  	
  However,	
  the	
  dip	
  in	
  S11	
  for	
  the	
  EM	
  simulation	
  should	
  be	
  much	
  greater	
  
than	
  the	
  dip	
  in	
  S11	
  for	
  the	
  schematic	
  simulation.	
  	
  Please	
  comment	
  on	
  why	
  this	
  is	
  and	
  turn	
  
in	
  your	
  comments	
  with	
  your	
  assignment.	
  (hint:	
  it	
  has	
  to	
  do	
  with	
  radiation).	
  	
  For	
  the	
  EM	
  
simulation	
  measurement,	
  note	
  that	
  the	
  resonant	
  frequency	
  is	
  about	
  2.954	
  GHz.	
  

8. Now	
  you	
  are	
  going	
  to	
  plot	
  the	
  radiation	
  patterns	
  of	
  the	
  patch	
  antenna	
  at	
  the	
  resonant	
  
frequency	
  2.954	
  GHz.	
  	
  Below	
  are	
  the	
  steps	
  you	
  can	
  take	
  to	
  accomplish	
  this:	
  
	
  

a. Choose	
  Options > Project Options.	
  Under	
  the	
  Frequency	
  tab	
  set	
  the	
  frequency	
  to	
  be	
  
a	
  single	
  frequency	
  by	
  checking	
  the	
  box	
  labeled	
  “Single	
  point”.	
  Set	
  the	
  frequency	
  
to	
  be	
  2.954	
  GHz	
  and	
  click	
  OK.	
  

b. Go	
  back	
  to	
  the	
  schematic	
  EM_Simulation.	
  Right	
  click	
  on	
  the	
  EXTRACT	
  block	
  and	
  
click	
  Properties.	
  In	
  the	
  Frequencies	
  tab,	
  check	
  the	
  box	
  that	
  says	
  “Use	
  project	
  
defaults”	
  and	
  click	
  OK.	
  Now	
  right	
  click	
  on	
  the	
  EXTRACT	
  block	
  and	
  choose	
  Add 
Extraction.	
  	
  

c. Once	
  the	
  simulation	
  is	
  done,	
  choose	
  Project > Add Graph.	
  Choose	
  Antenna	
  Plot	
  
(instead	
  of	
  Rectangular	
  like	
  we	
  did	
  above).	
  	
  Right	
  click	
  on	
  the	
  graph	
  and	
  select	
  
Add New Measurement.	
  Make	
  sure	
  Data	
  Source	
  Name	
  is	
  set	
  as	
  EM_Extract_Doc.	
  In	
  
the	
  box	
  labeled	
  “Measurement	
  Type”,	
  choose	
  Electromagnetic	
  à	
  Antenna	
  à	
  
Sweep	
  Phi.	
  In	
  the	
  box	
  labeled	
  “Measurement”	
  choose	
  “Con-­‐TPwr”	
  to	
  measure	
  
the	
  total	
  power	
  radiation	
  pattern.	
  	
  Click	
  Apply.	
  Now	
  change	
  the	
  “Measurement	
  
Type”	
  to	
  Electromagnetic	
  à	
  Antenna	
  à	
  Sweep	
  Theta.	
  	
  In	
  the	
  box	
  labeled	
  
“Measurement”	
  choose	
  “PPC_TPwr”.	
  	
  Click	
  Apply.	
  In	
  the	
  box	
  labeled	
  “Sweep	
  
Freq”	
  click	
  on	
  the	
  little	
  box	
  with	
  a	
  forward	
  bracket	
  “>”.	
  Choose	
  the	
  option	
  
“FSAMP:	
  {2.954}	
  GHz	
  (n=1).”	
  We	
  need	
  to	
  do	
  this	
  because	
  we	
  have	
  the	
  AFS	
  
(Automatic	
  Frequency	
  Sweep)	
  option	
  on	
  in	
  our	
  simulation.	
  	
  Click	
  apply	
  and	
  then	
  
click	
  OK.	
  

d. In	
  the	
  Project	
  Browser	
  right	
  click	
  on	
  EM_Extract_Doc	
  under	
  EM Structures and	
  
select	
  Options.	
  In	
  the	
  General	
  tab,	
  click	
  on	
  the	
  check	
  box	
  labeled	
  “Currents”	
  to	
  
save	
  the	
  simulated	
  currents	
  to	
  the	
  document	
  and	
  click	
  OK.	
  If	
  a	
  warning	
  dialog	
  
box	
  appears,	
  click	
  OK.	
  



e. In	
  the	
  Project	
  Browser	
  right	
  click	
  on	
  EM_Extract_Doc	
  under	
  EM Structures.	
  Select	
  
Force Re-Simulation.	
  If	
  a	
  warning	
  dialog	
  box	
  appears,	
  click	
  OK.	
  	
  

f. Now	
  simulate	
  again	
  by	
  choosing	
  Simulate > Analyze.	
  The	
  simulation	
  should	
  be	
  
pretty	
  fast	
  since	
  you	
  are	
  only	
  simulating	
  one	
  frequency	
  point.	
  The	
  plot	
  of	
  your	
  
radiation	
  pattern	
  should	
  look	
  like	
  that	
  shown	
  in	
  Figure	
  3.	
  	
  

	
  
9. Turn	
  in	
  a	
  plot	
  of	
  your	
  radiation	
  patterns	
  with	
  your	
  assignment.	
  What	
  is	
  the	
  half	
  power	
  

(3dB)	
  beamwidth	
  in	
  degrees	
  (for	
  theta)?	
  
10. Now	
  you	
  will	
  be	
  plotting	
  the	
  current	
  distribution	
  on	
  the	
  antenna	
  at	
  2.954	
  GHz.	
  To	
  do	
  

this:	
  
	
  

a. Right	
  click	
  on	
  EM_Extract_Doc	
  under	
  EM Structures in	
  the	
  Project	
  Browser.	
  Choose	
  
Add Annotation.	
  Make	
  sure	
  the	
  measurement	
  type	
  is	
  selected	
  as	
  Planar	
  EM	
  from	
  
the	
  options	
  in	
  the	
  box	
  labeled	
  “Measurement	
  Type”.	
  Now	
  select	
  EM_CURRENT	
  
from	
  the	
  options	
  in	
  the	
  box	
  labeled	
  “Measurement”.	
  	
  .	
  In	
  the	
  box	
  labeled	
  “Sweep	
  
Freq”	
  in	
  the	
  bottom	
  right,	
  click	
  on	
  the	
  little	
  box	
  with	
  a	
  forward	
  bracket	
  “>”.	
  
Choose	
  the	
  option	
  “FSAMP:	
  {2.954}	
  GHz	
  (n=1).”	
  Press	
  OK.	
  	
  

b. Right	
  click	
  again	
  on	
  EM_Extract_Doc	
  under	
  EM Structures in	
  the	
  Project	
  Browser.	
  
Choose	
  Options.	
  In	
  the	
  tab	
  labeled	
  General,	
  check	
  the	
  box	
  labeled	
  “Currents”	
  and	
  
click	
  OK.	
  A	
  warning	
  dialog	
  box	
  may	
  show,	
  click	
  OK	
  again.	
  	
  

c. Right	
  click	
  again	
  on	
  EM_Extract_Doc	
  under	
  EM Structures in	
  the	
  Project	
  Browser.	
  
Choose	
  Force Re-simulation.	
  

d. Now	
  simulate	
  again	
  by	
  choosing	
  Simulate > Analyze.	
  	
  
e. After	
  the	
  simulation	
  is	
  complete,	
  right	
  click	
  again	
  on	
  EM_Extract_Doc	
  under	
  EM 

Structures in	
  the	
  Project	
  Browser.	
  Choose	
  View EN 3D Layout.	
  In	
  the	
  upper	
  right	
  of	
  
the	
  screen	
  in	
  the	
  toolbar	
  you	
  should	
  see	
  a	
  forward	
  arrow	
  (the	
  animate	
  play	
  
button).	
  Press	
  this	
  button	
  to	
  animate	
  the	
  current.	
  You	
  should	
  see	
  the	
  standing	
  
wave	
  pattern	
  on	
  the	
  patch	
  antenna.	
  Pause	
  the	
  animation	
  when	
  the	
  standing	
  
wave	
  is	
  most	
  prominent,	
  take	
  a	
  screenshot,	
  and	
  turn	
  in	
  this	
  screenshot	
  with	
  
your	
  assignment.	
  	
  

	
  
	
  

	
  
	
  

Figure	
  3.	
  Radiation	
  pattern	
  for	
  microstrip	
  patch	
  antenna	
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